Home PCGS Set Registry Forum

My cert number appears to not be working......

Need some help on my next steps to take. I recently purchased two coins for my registry set from the same seller. The seller included the TrueView for one coin but not the other. No problem I thought, it will just be uploaded later. I received the coins yesterday. I tried to add them to my set, but only the coin with the TrueView could be added. The other coin appeared to upload to my set when I scanned the barcode but it never added. When I check the Cert #, it shows that it is in a “private set”, but I feel that is incorrect because this is a newly graded coin? It does not give me the option to contact PCGS to have it removed. To top it off, the TrueView still doesn’t load, and it shows that the coin is a Top Pop, which it obviously isn’t as it is graded XF40. Sorry for the long story.
Any help would be appreciated.
Thank you

Successful buys on BST board from NotSure, Nankraut, Yorkshireman, Astrorat, Ikeigwin(2x), Bob13, Outhaul, coinbuf, dpvilla, jayPem, Sean1990, TwoKopeiki, bidask, Downtown1974, drddm, nederveit2


Sign In or Register to comment.